Adjusting Wildcard Module for Sitecore 8+

Hi there,

If you ever decide to use Wildcard module on the Sitecore 8+ solution, you will find that wildcard rules editor doesn’t work as expected.

This happens because the Rules tree structure has been changed a bit since Sitecore 7.1. (read more)

Below you will find a set of steps to perform in order to re-enable the wildcard module for Sitecore 8.

1. Add new Wildcards Element under the  /sitecore/system/Settings/Rules/Definitions/Elements folder

2. Move every Action/Condition from /sitecore/system/Settings/Rules/Wildcards  subfolders to the Wildcards element created before. You can delete the old item if you want.
The result should look like this:

Screenshot 2016-08-30 16.10.46.png

3. Add a new Wildcards tag under /sitecore/system/Settings/Rules/Definitions/Tags

4. Navigate to the Wildcards tag configuration item  /sitecore/system/Settings/Rules/Definitions/Elements/Wildcards/Tags/Default and select the Wildcards tag from the list:

Screenshot 2016-08-30 17.07.02.png

 

5. Create a new Wildcards Rule Context Item under /sitecore/system/Settings/Rules

6. Select a Wildcards tag in the Tags list for the above created Rule context item:

Screenshot 2016-08-30 17.10.07.png

7. Finally, go to the /sitecore/templates/Wildcards/Route template and set /sitecore/system/Settings/Rules/Wildcards as Rules field datasource.

As a result, you can edit the wildcard rules as expected:

Screenshot 2016-08-30 17.12.21.png

We Rock!:)

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s